Mitsubishi Outlander Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Today I took 2 trips in my 2022 MITSUBISHI OUTLANDER. The first trip, about 180 miles, traffic, used cruise and radar, no issues.
The second trip about 5 miles in, I get a Warning, Malfunction light! Cruise disengaged. Unable to reset. I slowed and pulled over. I got out and looked at the front camera, which I turned on as I was parking and it looked ok. As I got back in the vehicle, the AC wasn't right and the motor head a slight miss all of a sudden. I turned off the engine and re started and it was fine the rest of the trip. I have a couple of other issues but I save for separate discussion! Thank you's All in advance!
 

Attachments

·
Registered
Joined
·
66 Posts
Hey @Nellthecar.

Sorry to hear about the issues. Have you reached out to your Mitsubishi dealer about it?
Starting with the easiest to diagnose and replace, I would recommend getting the Starting Battery checked. They can go at any time, even on brand new cars (but not common), and do show early symptoms like this.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Hey @Nellthecar.

Sorry to hear about the issues. Have you reached out to your Mitsubishi dealer about it?
Starting with the easiest to diagnose and replace, I would recommend getting the Starting Battery checked. They can go at any time, even on brand new cars (but not common), and do show early symptoms like this.
I believe it to be more likely electronics. It's a brand new car. The battery is fine. I have not yet contacted service
 
1 - 3 of 3 Posts
Top